Server outage
Incident Report for Lookback
Resolved
This incident has been resolved. It was caused by an update to our servers that temporarily made them lose connection with each other.
Posted 11 months ago. May 10, 2018 - 13:54 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 11 months ago. May 10, 2018 - 13:34 PDT
Investigating
We are currently investigating this issue.
Posted 11 months ago. May 10, 2018 - 13:22 PDT
This incident affected: Lookback.io, Live, and Uploading.