Lookback.io is not loading in Safari
Incident Report for Lookback
Resolved
This incident has been resolved.
Posted almost 3 years ago. Oct 26, 2016 - 15:08 PDT
Identified
No version of Safari can't load lookback.io at the moment. We have a fix to be deployed.
Posted almost 3 years ago. Oct 26, 2016 - 14:14 PDT