Users are unable to start sessions
Incident Report for Lookback
Resolved
We have resolved this incident.
Posted Oct 17, 2019 - 13:03 PDT
Monitoring
We have identified the root cause of the issue and are continuing to monitor the situation.
Posted Oct 17, 2019 - 12:39 PDT
Update
Functionality should now be restored for customers. We are continuing to investigate the root cause of this issue.
Posted Oct 17, 2019 - 12:29 PDT
Investigating
We are investigating reports of users being unable to start live, in-person, and self test sessions.
Posted Oct 17, 2019 - 12:14 PDT
This incident affected: Participate landing page.