Android app temporarily unavailable
Incident Report for Lookback
Resolved
The Android application has now been restored
Posted Jul 03, 2024 - 02:05 PDT
Identified
We believe we have resolved the issue and are waiting for the app to be restored to the play store
Posted Jul 02, 2024 - 15:53 PDT
Investigating
Google has temporarily removed the Participate App from the Android App Store. We are working to resolve the underlying issue and restore the app. While the app is not listed participants who do not already have the app cannot download it, those that have it can continue using it.
Posted Jul 02, 2024 - 15:52 PDT
This incident affected: Participate apps (Participate for Android).