Lookback.io is unreachable
Incident Report for Lookback
Resolved
This incident has been resolved.
Posted almost 3 years ago. Nov 01, 2016 - 15:19 PDT
Investigating
Lookback.io is currently down for all users.
Posted almost 3 years ago. Nov 01, 2016 - 14:34 PDT