Not possible to create new organizations, slow loading of dashboard, organization settings, and player

Incident Report for Lookback

Resolved

All systems are operational. We're continuing to keep an eye out on any degraded performance when it comes to organization creation from new signups, as well as loading times.
Posted Feb 20, 2023 - 10:56 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 20, 2023 - 08:55 PST

Update

Slow loading times are gone, but we're continuing to investigate the core issue. Team creation might still be slow and not work.
Posted Feb 20, 2023 - 08:33 PST

Investigating

We are currently investigating this issue.
Posted Feb 20, 2023 - 07:13 PST
This incident affected: Dashboard, Player, and Settings & Billing.