Users may be unable to download recordings
Incident Report for Lookback
Resolved
We have confirmed that download functionality is now fully operational for all users again.
Posted 28 days ago. Jul 23, 2019 - 13:22 PDT
Monitoring
We have addressed issues related to some recordings being unavailable for download and have confirmed that downloads are processing correctly again.
Posted 28 days ago. Jul 23, 2019 - 13:01 PDT
Identified
We have identified why some recordings cannot be downloaded and are working to address it now.
Posted 28 days ago. Jul 23, 2019 - 12:29 PDT
Investigating
Some users have notified us that they are unable to download recordings. We have confirmed this and are investigating now.
Posted 28 days ago. Jul 23, 2019 - 12:01 PDT
This incident affected: Processing.