Some customers are having issues loading the dashboard or videos

Incident Report for Lookback

Resolved

Errors have subsided and this incident has been marked as resolved.
Posted Apr 20, 2020 - 12:06 PDT

Monitoring

We've introduced a fix and are no longer encountering this behavior, we will continue to monitor the situation.
Posted Apr 20, 2020 - 11:45 PDT

Investigating

We are currently investigating an issue where some customers are unable to load their dashboard or videos.
Posted Apr 20, 2020 - 11:37 PDT
This incident affected: Dashboard.