Session downloads unavailable
Incident Report for Lookback
Resolved
We have taken steps to address users being unable to download sessions and highlights.
Posted 8 months ago. Mar 05, 2019 - 16:36 PST
Investigating
We've received reports of being unable to download sessions and highlights and are currently investigating.
Posted 8 months ago. Mar 05, 2019 - 15:06 PST
This incident affected: Processing.