Lookback.io is not responding
Incident Report for Lookback
Resolved
We have resolved the issues impacting Lookback.io as well as Self-Test and Live sessions and have confirmed that they are now functioning correctly.
Posted 3 months ago. May 20, 2019 - 17:56 PDT
Identified
We have identified the issue and have restored partial functionality to the site. Self-Tests and Live sessions cannot be uploaded at this time and we are continuing to troubleshoot the issue.
Posted 3 months ago. May 20, 2019 - 17:09 PDT
Investigating
We are currently investigating a site outage due to a service update and will provide updates as they are available.
Posted 3 months ago. May 20, 2019 - 16:09 PDT
This incident affected: Lookback.io.